App Store ป่วน !! ผู้ใช้ iOS 9 Beta ให้คะแนนรีวิวต่ำเพราะแอพไม่รองรับ

App-Store-logo

เมื่อต้นสัปดาห์ Apple ได้เปิดให้ผู้ใช้ทั่วไปทดสอบ iOS 9 และ OS X El Capitan แบบ Public Beta ซึ่งแน่นอนว่าซอฟต์แวร์เวอร์ชันทดสอบจะเกิดปัญหาเยอะกว่าเป็นปกติ จึงเกิดปัญหาเมื่อเปิดให้ทดสอบเพียงไม่กี่วันผู้ใช้ก็ให้คะแนนรีวิวแอพที่มีปัญหาเมื่อใช้กับซอฟต์แวร์เวอร์ชันทดสอบต่ำมาก

ยกตัวอย่างเช่น นักพัฒนา Day One โพสต์ภาพผ่านทวิตเตอร์ว่ามีคนให้คะแนนแอพ 1 ดาว โดยบอกว่าแครชเมื่อใช้กับ iOS 9 Beta

ซึ่งหลังจากทีมงาน MacThai เข้าไปสำรวจคะแนนรีวิวแอพยอดนิยมอย่าง LINE ที่มีปัญหากับ iOS 9 ก็มีคนจำนวนหนึ่งให้คะแนนรีวิวต่ำพร้อมความเห็นว่าใช้กับ iOS 9 แล้วมีปัญหา

ios-9-beta-line ios-9-beta-line-2

แม้ Apple จะเคยให้ทดสอบแบบ Public Beta มาตั้งแต่ iOS 8.3 แล้ว แต่การปล่อยให้ทดสอบ iOS 9 เป็นการปล่อย iOS เวอร์ชันใหญ่ให้ผู้ใช้ทั่วไปทดสอบเป็นครั้งแรก ฉะนั้นจึงเกิดปัญหากับแอพหนักกว่า iOS 8.3 Beta ส่งผลให้ผู้ใช้รีวิวแอพด้วยคะแนนต่ำใน App Store ทั้งที่ควรรายงานปัญหาต่อนักพัฒนาแอพดังกล่าวโดยตรง

กฏของ App Store อนุญาตให้นักพัฒนาส่งแอพเพื่อรองรับ iOS หรือ OS X เวอร์ชันใหม่ให้ Apple พิจารณาได้เพียงไม่กี่สัปดาห์ก่อน iOS หรือ OS X รุ่นใหม่จะปล่อยเท่านั้น ฉะนั้นแม้นักพัฒนาอยากจะส่งอัพเดตเพื่อแก้ปัญหาก็ทำไม่ได้ นักพัฒนาจึงต้องรอให้ Apple จัดการปัญหานี้เท่านั้น

เนื่องจากผู้ใช้หลายคนจะพิจารณาจากคะแนนรีวิวแอพก่อนติดตั้ง รวมถึงการจัดอันดับบางอย่างจะใช้คะแนนรีวิวเป็นเกณฑ์ ฉะนั้นนักพัฒนาจะสูญเสียรายได้เพราะแอพจะมีคนโหลดน้อยลง อาจส่งผลให้อันดับใน App Store ร่วงลงอีกด้วย ทั้งที่ไม่ใช่ความผิดของเขาและแก้ไขเองไม่ได้ด้วย

ผู้นำเสนอปัญหาอย่าง MacStories แนะนำทางแก้ว่า Apple ควรจะปิดการรีวิวแอพสำหรับ Apple ID ที่ลงทะเบียนทดสอบใน Apple Beta Software Program และปลดล็อคเมื่อเปิดตัวเวอร์ชันเต็ม รวมถึงแจ้งรายละเอียดเรื่องนี้ไว้ในหน้า FAQ ด้วย

ทีมงาน MacThai มีคำแนะนำสำหรับผู้ใช้ที่ทดสอบ iOS 9 และ OS X 10.11 ดังนี้

  • พึงระลึกไว้เสมอว่าท่านกำลังใช้ซอฟต์แวร์เวอร์ชันทดสอบที่สามารถเกิดปัญหาได้ทุกเมื่อ
  • อย่าเขียนรีวิวแอพแบบเสียหายหรือให้คะแนนต่ำใน App Store เมื่อพบปัญหากับแอพให้แจ้งนักพัฒนาแอพนั้นโดยตรง
  • หากพบปัญหากับแอพหลักของเครื่อง ให้รายงานผ่านทางแอพ Feedback ที่ถูกติดตั้งมาแล้วในเครื่อง
  • หากแอพที่จำเป็นต้องใช้พบปัญหาไม่สามารถใช้ได้กับ iOS 9 หรือ OS X 10.11 เวอร์ชันทดสอบ ควรกลับไปใช้ iOS 8.4 หรือ OS X 10.10.4 เพื่อจะได้ไม่เสียงานที่จะทำครับ

ที่มา – MacStories

prepare-ios-device-for-ios-9-public-beta

prepare-mac-for-os-x-el-capitan-beta