Apple เตือนนักพัฒนา watchOS 5 จะไม่รองรับแอปเก่า ๆ และไม่มีอัปเดต

watchos-4-3-1-hints-at-future-watchkit-app-incompatibility 2

ล่าสุด watchOS 4.3.1 beta ได้มีข้อความแจ้งเตือนเมื่อเปิดแอปที่ยังคงใช้ WatchKit ตั้งแต่เวอร์ชัน watchOS 1 ว่าแอปนี้จะไม่สนับสนุนบน watchOS 5 แล้ว นักพัฒนาควรอัปเดตแอปบน Apple Watch ด่วน !!

ถ้าใครยังจำกันได้ แอปที่รันบน watchOS 1 นั้นมีความช้า ค้าง และการเชื่อมต่อเข้ากับไอโฟนไม่ค่อยมีความเสถียร ทำให้แอปเปิลได้เปิดตัว watchOS 2 ภายในเวลาไม่ถึง 6 เดือนหลังจาก Apple Watch รุ่นแรกเปิดตัว

ซึ่ง Apple Watch รุ่นล่าสุดนั้นมีชิปประมวลผล Apple W2 ที่แรงกว่ารุ่นแรกพอสมควร ทำให้การรันแอปบน Apple Watch นั้นมีความเสถียรและมีประสิทธิภาพดีขึ้นอย่างเห็นได้ชัด สำหรับการประกาศเลิกสนับสนุนแอปเก่า ถือว่าแอปเปิลทำถูกแล้ว ซึ่งจะผลักดันให้แอปรองรับอุปกรณ์รุ่นใหม่ ๆ มากขึ้น

watchos-4-3-1-hints-at-future-watchkit-app-incompatibility

สุดท้ายสำหรับ watchOS 5 น่าจะเปิดตัวในงาน WWDC 2018 ที่จะจัดขึ้นในวันที่ 4 มิถุนายนที่จะถึงนี้ ต้องมาคอยดูกันว่า จะมีฟีเจอร์อะไรใหม่ ๆ มาให้ใช้บ้าง

 

ที่มา – 9to5Mac